Problemy z PHP 4.3.10

Archived under Programming on December 31st, 2004 with no comments

Przedwczoraj i przez większą część wczorajszego dnia strona nie działała, wyświetlając przy tym uroczy komunikat o błędzie PHP (huh, muszę w końcu poczytać coś o projektowaniu defensywnym ;) ). Przyczyną była aktualizacja PHP na serwerze do wersji 4.3.10.

Jeżeli ktoś śledzi, co się ostatnio dzieje wokół bezpieczeństwa PHP, pewnie wie, że doczekaliśmy w końcu naprawdę destrukcyjnych i niebezpiecznych robaków. Często wykorzystują one szkolne błędy i niechlujstwo, ale czasem wina tkwi po stronie interpretera i konieczna jest jego aktualizacja.

PHP 4.3.10 wprowadza m.in. zmiany w implementacji pętli foreach. Problem w tym, że jeśli na serwerze są zainstalowane pewne aplikacje optymalizujące działanie skryptów, np. Zend Optimizer, wiele skryptów PHP (np. Smarty) może przestać działać. Pomaga aktualizacja Optimizera do najnowszej wersji i oczyszczenie jego pamięci podręcznej (cache). Mam nadzieję, że ta informacja zaoszczędzi komuś kłopotów.

Comments are closed